[RESOLVED] Issue with phone vendor impacting calls to Firespring Tuesday 21st June 2022 09:38:00


[RESOLVED] Our phone vendor has resolved this issue.


We are currently experiencing an issue with our phone system that may prevent calls from coming in and being routed to the support team. We are working with our vendor to resolve this issue as soon as possible. We appreciate your patience and we will update this status when we have more information.

In the meantime, please email support@firespring.com and our support team will assist you via email.