[RESOLVED] Issues with the Campaign Editor not loading Friday 21st October 2022 12:13:00


Update: Our teams have pushed out an update to allow the editor to load as expected now. If you experience any intermittent loading, you may need to clear your browser's cache and cookies. Out of an abundance of caution, we will continue to monitor our app for some time. We will also provide updates as soon as possible.


We're receiving reports that our editor will not load drafts (both legacy and new editor campaigns) or allow for creating new campaigns. Our teams are currently investigating the cause of the issue, and we will post an update as soon as we have more details. Thank you for your patience while we work on resolving the issue.