[UPDATE 11/7/22 8:10 AM] Email users unable to log in to third-party mail clients (i.e Outlook/MAC etc) Wednesday 2nd November 2022 09:36:00


[UPDATE] Our email Engineers have identified the Issue and continue to actively work towards a full resolution. A small sub-set of users may still be impacted and our Engineers are working on a global fix. Some users are reporting a forced pop-up to re-enter username and password. This is not a prompt to change your password, so you do not need to change any login credentials.

We'll update here as we get more updates.


Our email support team is investigating an issue where affected users may be unable to log in to third-party mail clients (i.e Outlook/MAC etc). Webmail is not impacted, so you can login at email.firespring.com to use webmail if you're experiencing any issues with your email client.

Mail delivery is not impacted.