[RESOLVED] Springboard outage Friday 20th January 2023 13:08:00


[RESOLVED] Springboards are accessible and fully operational.

Engineers are investigating an outage with the Springboard platform. We will provide further information here as it becomes available.