[RESOLVED] Firespring phone support is currently down due to a provider outage Monday 3rd April 2023 15:18:00


[RESOLVED] Firespring phone support is currently down due to a provider outage. We're monitoring the issue as our phone provider works towards a resolution. In the meantime, please email support@firespring.com and our team will follow up with you. Thank you for your patience.