[RESOLVED] Reports of users unable to login to email Wednesday 31st May 2023 15:05:00


[RESOLVED] We have resolved the Webmail login issue. Users are able to login at this time.

=================

Our Support team is investigating reports of users being unable to login to email at email.firespring.com. We're working with our email partner to identify the cause and the solution. We'll update here as we know more about the situation and expected down time.

Currently, this only appears to be impacting webmail. Third party email clients like Outlook, Mac Mail, Thunderbird, etc. appear to be functioning correctly.