[RESOLVED] Email/Webmail connection errors Wednesday 7th June 2023 10:46:00


[RESOLVED] Reports of users unable to login to email


We are investigating reports of users being unable to login to webmail at https://email.firespring.com. We're working with our email partner to identify the cause and the solution. We'll update here as we know more about the situation and expected down time.