[Resolved] Springboard slow-moving Wednesday 6th September 2023 11:11:00


[Resolved] Springboard is now functioning at its normal speed.

===================

We are reviewing the status of the Springboard being unresponsive at times. It may perform slowly or fail to load pages.