[Resolved] Webmail Friday 15th September 2023 08:23:00


[Resolved] A solution has been put in place. Users are now able to connect their webmail. We are still investigating the incident posted Wednesday, September 13, regarding website form submissions and expected email notifications & responses.


We are aware of some issues related to webmail. Users may experience some login issues and/or other errors related to sending & receiving. At this time the issues seem to be limited to webmail. Other POP/IMAP email programs like Outlook, MacMail, etc are unaffected.