[Resolved] Delayed Email Delivery Notification Wednesday 20th September 2023 12:03:00


[Resolved] The issue below has been resolved. Late and duplicate emails should have only arrived in inboxes on 9/19 for the date range of 9/1-9/5.

Our team has identified an issue with email notifications reaching mailboxes. This impacting is for emails that were supposed to be delivered between 9/1/23-9/5/23.

You may receive late emails arriving in your mailbox or you may receive duplicate emails arriving in your mailbox.

We suggest looking at your Springboard Message Center to make sure you aren't missing any form/file transfer submissions as this area is not impacted by this.