[Resolved] Springboard Down Thursday 28th September 2023 15:31:00


[Resolved] Springboard is performing normally.


We are currently investigating an issue causing the Springboard to be inaccessible.