[Resolved] Springboard Outage Thursday 19th October 2023 14:30:00


[Resolved] The issue causing an outage with the Springboard website which produced an error stating "Something went wrong with this operation" has now been resolved.