[Resolved] Email undeliverable to recipients of Yahoo network Tuesday 24th October 2023 09:38:00


[Resolved] Emails to the listed recipient domains are reportedly delivering.


We are aware of issues emailing to users within the Yahoo organization. Our email admin team is investigating blocks on varied mail server IPs. At this time it only appears to affect emailing to users with domains within this network such as bellsouth.net, pacbell.net, sbcglobal.net, att.net, yahoo.com and related others. Temporarily, you may have to communicate information to these users by other means if you receive such an undeliverable rejection. Recipients can try safelisting sending addresses, domains, or offending IPs found in the rejection.

*We are still monitoring a previous incident regarding website email notifications random delays.