RESOLVED: Possible email issues due to global outage Friday 19th July 2024 08:27:00


[Resolved] There are possible performance issues with email related to this morning's global outage. This outage is a result of a recent update by cybersecurity firm CrowdStrike, which has caused widespread disruptions for various industries worldwide. Some users of other mail programs could be affected. At this time, webmail is unaffected. Login to webmail at https://email.firespring.com/ should you experience issues with your 3rd party mail program.