[Resolved] Unable to access Springboard (Red error page) and Website outage. Thursday 22nd August 2024 12:13:00


[Resolved] Our team has identified and fixed the issue that caused websites and Springboard sites to be down.