[Resolved] Webmail Tuesday 7th January 2025 08:56:00


[Resolved] The issue impacting logging into webmail has since been resolved.

We are currently facing issues with webmail login. Our email provider is actively working to resolve the issue. Please note that email delivery remains unaffected.

POP/IMAP is unaffected and can be used as an alternative while webmail access is unavailable. Here's the link to setup - https://emailhelp.rackspace.com/