[Resolved] Slow website load times. Thursday 20th March 2025 09:12:00


[Resolved] Our team is aware of slow load times in the Springboard and the front end Websites. We are actively investigating.