[Resolved] Slow Springboard load times. Tuesday 25th March 2025 13:13:00


[Resolved] Our team is aware of slow load times in the Springboard. We are actively investigating the cause.