[Resolved] Performance issues due to AWS outages Monday 20th October 2025 13:21:00
[Resolved] AWS has reportedly corrected their outage.
Due to AWS (Amazon Web Services) outages, we are seeing intermittent issues with hosted web sites and Springboard. We are not alone. The AWS issues are affecting other services beyond Firespring.