Resolved: Webmail Connectivity and Delivery Delays Wednesday 26th June 2019 20:17:00


*RESOLVED


Original post: Our Engineers are investigating a disruption with our Hosted Email services. Users will experience slowness when accessing their email. This includes slowness accessing webmail, loading messages, attachments, and connecting using IMAP and POP3. Users may also receive the below error in webmail:

[SERVERBUG] Internal error occurred. Refer to server log for more information.

Incoming email is impacted as well for all Hosted Email users.