[RESOLVED] Issue processing print-ready files Friday 12th February 2021 18:38:00


[RESOLVED] Our Engineers are investigating an issue where users are unable to process and download print-ready files in the Springboard. We'll update that status here once we've rolled out a fix.

Update: This issue has been resolved and everything should be functioning. Please notify our Support team if you are experiencing any issues.