[RESOLVED]: Reports of duplicate email notifications being sent from website form submissions Monday 15th February 2021 13:00:00


[RESOLVED]: We're investigating reports of duplicate email notifications being sent from website form submissions when users are placing an order, making a donation, etc. Thank you for your patience while we troubleshoot the issue.

Update: Our Engineers discovered the issue causing the multiple email instances, have resolved the issue, and are implementing a fix to ensure it doesn't happen again in the future. If you continue to receive any duplicate emails, please contact our Support team for assistance.