[RESOLVED] Reported incidents of slowness in the Springboard Wednesday 2nd June 2021 10:00:00


Our Engineers are investigating issues causing slowness when working in the Springboard. We're working towards a quick fix and will update here once everything is back to normal.

Update: We are now seeing Springboard speed increase, everything should be recovering or starting to recover.