[RESOLVED] Reported issues involving VersaDoc Wednesday 9th June 2021 14:51:00


UPDATE: We are now seeing VersaDoc items proof and download as expected.

Our Engineers are investigating issues causing slowness, preview errors, and download failures for VersaDoc items. We're working towards a quick fix and will update here once everything is back to normal.