[RESOLVED] Webmail connectivity issues for small sub-set of users Wednesday 30th June 2021 09:00:00


[RESOLVED]

[Update]: Affected users utilizing Webmail may experience intermittent error prompts. Impacted users are encouraged to clear their browser cache or try utilizing a private browsing window. Engineers are engaged and working toward a resolution. Mail delivery is not impacted.

[Original post]: We are investigating reports of connectivity issues to our Hosted Email environment affecting a small sub-set of users on the Webmail platform. Users may experience an error prompt upon logging in, navigating or sending messages. We are actively working towards a full resolution. This small sub-set of users may continue to encounter intermittent error prompts at this time. We'll update our status page once we know more or as a resolution has been reached.