[Update: Monitoring Fix] Webmail Issues Friday 2nd July 2021 12:00:00


[UPDATE]: A potential solution has been put in place and more details will be posted as they become available. Affected users utilizing Webmail who still experience intermittent error prompts are encouraged to clear their browser cache or try utilizing a private browsing window.


Affected users utilizing Webmail may experience intermittent error prompts. Impacted users are encouraged to clear their browser cache or try utilizing a private browsing window. Engineers are engaged and working toward a resolution. Mail delivery is not impacted.