[Investigating - Local phone number is working] Firespring phone support is still down (phone provider experiencing technical difficulties) Monday 20th September 2021 09:02:00


Update 11:49 AM (CST): Calls appear to be working successfully for the local line (402-437-0000), but our direct support phone number (877-447-8936) appears to still be experiencing issues. If possible, please call our local number (402-437-0000) for support or email support@firespring.com


Update: We've been able to successfully restore incoming and outgoing call functionality with our phone provider. With the lines now working correctly, we may experience a slightly longer hold time based on incoming volume.

Thank you for your patience. If you have any issues connecting with our teams via phone, you can email us at support@firespring.com


Our phone provider is still experiencing issues with their system. This is preventing us from being able to accept incoming calls or dial outbound. Our IT team is actively working with their support team on potential workarounds. If you need to contact support, you can:

  1. Review our online 24/7 support resources from your Springboard found under the Support > FAQs link (or go to firespring.com/client-area)

  2. Contact support using the chat feature in your Springboard to chat online with our support team

  3. Submit a contact form from your Springboard under the Support > Contact Us link

  4. Email us at support@firespring.com

Thank you for your patience while our team works with our phone provider on this issue.