[RESOLVED] Webmail login page loading error Monday 18th October 2021 08:08:00


Update: This issue should now be resolved and users should be able to resume email login at email.firespring.com


We are investigating an issue with the webmail login page preventing users from being able to login to that page. We'll post here once we know more or when we've resolved the issue. We've had reports of clients being able to access webmail if refreshing or waiting a minute or two between refresh or login attempts.

Our email host, Rackspace, recommends users access their email via a mail client such as Outlook as a workaround.

Email delivery is not impacted at this time.