[RESOLVED] AWS outage is impacting PaymentSpring's ability to process charge requests on payments Tuesday 7th December 2021 12:03:00


UPDATE: Resolved. Amazon Web Services has restored their services and PaymentSpring has confirmed that their systems are now functioning as expected.


Amazon Web Services (AWS) is currently experiencing an issue that is impacting PaymentSpring and preventing charge requests for payments. Our Engineers and PaymentSpring are aware of the issue and will update here as we know more from AWS on the solution.

If you have an alternate gateway like PayPal or Authorize.net, you can switch your payment gateway to one of these providers in your Springboard's website settings > payment gateways area.