[RESOLVED] Potential issue with PaymentSpring ACH validation Thursday 9th December 2021 09:52:00


[UPDATE] This issue has been resolved.


The PaymentSpring team is currently researching an issue with the ACH validation service. All teams are actively engaged and researching the issue and potential impact. We'll update here as we know more.