[RESOLVED] Possible AWS outage affecting PaymentSpring systems Wednesday 15th December 2021 10:34:00


[UPDATE] This issue has been resolved.

PaymentSpring is reporting a possible AWS outage that is impacting the ability to process charge requests. This may be impacting access to all PaymentSpring systems and submitting payments through websites. Customers may have transactions delayed or not processed. Charge requests may timeout or they may process after a significant delay. Number of requests impacted is undertermined at this time. Access to any PaymentSpring Portal or Dashboard may be limited or not accessible at all.