[RESOLVED] Dropped calls and unable to contact Firespring by phone Thursday 16th December 2021 11:01:00


[Update]: Phone systems are once again operational.


We are investigating an issue resulting in dropped calls and failed attempts to contact us by phone. If you have difficulties reaching us by phone and need to contact our support team, you can:

  1. Review our online 24/7 support resources from your Springboard found under the Support > 'FAQs' link (or go to firespring.com/client-area).
  2. Submit a contact form from your Springboard under the Support > 'Contact Us' link.
  3. Email us at support@firespring.com
  4. Contact support using the chat feature in your Springboard to chat online with our support team (this channel is currently based on availability of our team members). Our chat bot can help you navigate some common FAQ and troubleshooting issues.

Thank you for your patience while our team investigates this issue.