[Fixed/Monitoring] Calls to and from our Lincoln phone system are down Monday 20th December 2021 11:33:00


Update: Calls appear to be going through. We will continue to monitor the situation.


Calls to and from our Lincoln phone system are currently down. Our IT team is investigating the issue with our phone provider as we work to resolve the issue. If you need any website or email hosting support, please email support@firespring.com