[RESOLVED] Email Marketing: Some users experiencing loading issues in Campaigns and Response Sections of the App Friday 14th January 2022 16:29:00


Update: We have deployed a solution that should resolve the issues we were seeing and are monitoring to see if everything has been resolved.


We have received reports of loading issues in the Campaigns and Response sections of the Emma application. This appears to be related to a third party provider, and we are investigating further.

Users experiencing this issue have had success clearing the cache and cookies on their browser and returning to the application.

We will continue to update as we get more information.