[RESOLVED] Springboard performance issues preventing users from accessing and using the Springboard Wednesday 13th April 2022 13:19:00


UPDATE: We fixed the issue and users should now be able to access the Springboard. Please contact our Support team if you continue to experience any issues or have any questions.


Our Engineers are working to fix an issue that is causing access and performance issues in the Springboard. We're working towards a quick fix and will update here once things return back to normal.