[FIXED] Intermittent Email Marketing issue preventing campaigns to load properly (including drafts) Tuesday 19th April 2022 14:06:00


[RESOLVED]

The issues should now be resolved. We are continuing to monitor the situation.


We are investigating issues where the Email Marketing email editor and draft campaigns are intermittently not loading. As a possible workaround, please try refreshing your browser if the page doesn't load.

We will continue to post updates as we receive them. Thank you for your patience.